summaryrefslogtreecommitdiffstats
path: root/debian/patches/0005-riscv64-link-pthread.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0005-riscv64-link-pthread.patch')
-rw-r--r--debian/patches/0005-riscv64-link-pthread.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/debian/patches/0005-riscv64-link-pthread.patch b/debian/patches/0005-riscv64-link-pthread.patch
new file mode 100644
index 000000000..782b6ed7b
--- /dev/null
+++ b/debian/patches/0005-riscv64-link-pthread.patch
@@ -0,0 +1,14 @@
+Description: Link with -pthread instead of -lpthread to fix FTBFS on riscv64
+Forwarded: no
+Last-Update: 2020-03-01
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,6 +25,7 @@
+
+ if(CMAKE_SYSTEM_NAME MATCHES "Linux")
+ set(LINUX ON)
++ set(THREADS_PREFER_PTHREAD_FLAG ON)
+ FIND_PACKAGE(Threads)
+ elseif(CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+ set(FREEBSD ON)