summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2024-11-10 15:31:03 +0100
committerDaniel Baumann <daniel@debian.org>2024-11-10 15:31:03 +0100
commit2b16d0d8a6bead5bcc2125b890bf1a13d19602dc (patch)
treeb67952daab2d78e87c103ed10ece33ad6a9a2167 /Makefile.am
parentInitial commit. (diff)
downloadhaveged-2b16d0d8a6bead5bcc2125b890bf1a13d19602dc.tar.xz
haveged-2b16d0d8a6bead5bcc2125b890bf1a13d19602dc.zip
Adding upstream version 1.9.14.upstream/1.9.14
Signed-off-by: Daniel Baumann <daniel@debian.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..3332110
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,18 @@
+## Process this file with automake to produce Makefile.in
+
+# Files to be included in distribution
+EXTRA_DIST = ent/entitle.gif init.d/service.fedora init.d/service.redhat \
+ init.d/sysv.lsb init.d/sysv.redhat nist/template9 \
+ contrib/diags/data_prep.c contrib/diags/bins.p contrib/diags/inc.p \
+ contrib/diags/lognorm.r contrib/diags/lognorm.sh \
+ haveged.spec contrib/build/build.sh contrib/build/lib.spec contrib/build/nolib.spec \
+ contrib/build/havege_sample.c contrib/build/fedora.spec
+
+# programs used in check targets
+EXTRA_PROGRAMS = ent/entest nist/nist
+
+# Build install script and tests as necessary
+SUBDIRS = src init.d man ent nist
+
+# check entire package
+DISTCHECK_CONFIGURE_FLAGS = "--enable-nistest"