summaryrefslogtreecommitdiffstats
path: root/ent/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ent/Makefile.am')
-rw-r--r--ent/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/ent/Makefile.am b/ent/Makefile.am
new file mode 100644
index 0000000..265504c
--- /dev/null
+++ b/ent/Makefile.am
@@ -0,0 +1,22 @@
+## Process this file with automake to produce Makefile.in.
+
+if ENABLE_ENT_TEST
+check_PROGRAMS = entest
+endif
+
+AM_CFLAGS=-Wall
+
+entest_LDADD = -lm
+
+entest_SOURCES = entest.c iso8859.c randtest.c chisq.c iso8859.h randtest.h
+
+CLEANFILES = sample
+
+MAINTAINERCLEANFILES = Makefile.in
+
+if ENABLE_ENT_TEST
+check-local:
+ ./entest -t ${srcdir}/entitle.gif
+ ../src/haveged -n 16384k -v 1 $*
+ ./entest -vf sample
+endif