summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..752f5f4
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,41 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.66"
+name = "terminal-prompt"
+version = "0.2.3"
+authors = ["Maarten de Vries <maarten@de-vri.es>"]
+publish = ["crates-io"]
+description = "Tiny library for prompting sensitive or non-sensitive data on the terminal"
+documentation = "https://docs.rs/terminal-prompt"
+readme = "README.md"
+keywords = [
+ "terminal",
+ "console",
+ "prompt",
+ "input",
+ "tty",
+]
+categories = [
+ "command-line-interface",
+ "os",
+]
+license = "BSD-2-Clause"
+repository = "https://github.com/de-vri-es/terminal-prompt-rs"
+
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.147"
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3.9"
+features = ["consoleapi"]